1.3(2) & 1.3(3) Service constantly crashes on Win 8.1 / 64

1.3(2) & 1.3(3) Service constantly crashes on Win 8.1 / 64

Postby sternenkrieger » 16 Jun 2014, 20:28

With Release 1.3(2) the CPVNM Service crashes constantly on my Win 8.1 64 bit System
I also tried the 1.3.(3) which was posted in another thread, same problem, it is also not possible to start the CPVNM Application with the console, it leads to an immediate crash of the app.

1.3.(1) works but it doesn't save the settings and I can't restore any snapshots, which is kind of frustrating

In the evenlog the following errors are logged:

Code: Select all
Fehlerbucket , Typ 0
Ereignisname: APPCRASH
Antwort: Nicht verfügbar
CAB-Datei-ID: 0

Problemsignatur:
P1: CPVNM.exe
P2: 1.3.3.0
P3: 5391b1a3
P4: CPVNM.exe
P5: 1.3.3.0
P6: 5391b1a3
P7: c0000005
P8: 0000000000018332
P9:
P10:

Angefügte Dateien:
C:\Windows\Temp\WER9963.tmp.appcompat.txt
C:\Windows\Temp\WER9974.tmp.WERInternalMetadata.xml
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_CPVNM.exe_ed6335619b5350b5daedcdec103e15b9118b19_404d4eb6_cab_1a599972\memory.hdmp
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_CPVNM.exe_ed6335619b5350b5daedcdec103e15b9118b19_404d4eb6_cab_1a599972\triagedump.dmp

Diese Dateien befinden sich möglicherweise hier:
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_CPVNM.exe_ed6335619b5350b5daedcdec103e15b9118b19_404d4eb6_cab_1a599972

Analysesymbol:
Es wird erneut nach einer Lösung gesucht: 0
Berichts-ID: 43b07052-f571-11e3-bfd7-1234567890ab
Berichtstatus: 96
Bucket mit Hash:


Code: Select all
Name der fehlerhaften Anwendung: CPVNM.exe, Version: 1.3.3.0, Zeitstempel: 0x5391b1a3
Name des fehlerhaften Moduls: CPVNM.exe, Version: 1.3.3.0, Zeitstempel: 0x5391b1a3
Ausnahmecode: 0xc0000005
Fehleroffset: 0x0000000000018332
ID des fehlerhaften Prozesses: 0x390
Startzeit der fehlerhaften Anwendung: 0x01cf898e66229190
Pfad der fehlerhaften Anwendung: C:\Program Files\CopperLan\CPVNM\CPVNM.exe
Pfad des fehlerhaften Moduls: C:\Program Files\CopperLan\CPVNM\CPVNM.exe
Berichtskennung: a7850d9a-f581-11e3-bfd7-1234567890ab
Vollständiger Name des fehlerhaften Pakets:
Anwendungs-ID, die relativ zum fehlerhaften Paket ist:
sternenkrieger
 
Posts: 8
Joined: 16 Jun 2014, 18:14

Re: 1.3(2) & 1.3(3) Service constantly crashes on Win 8.1 /

Postby CopperPhil » 16 Jun 2014, 20:35

Hi,

Do you have any MIDI device currently handled by CopperLan?
If so, is it still crashing if you unplug all MIDI devices?

Another test would be trying a fresh installation: uninstall CopperLan, reboot, and then re-install the 1.3(3) version.
CopperPhil
 
Posts: 471
Joined: 30 Mar 2011, 15:02
Location: Brussels

Re: 1.3(2) & 1.3(3) Service constantly crashes on Win 8.1 /

Postby sternenkrieger » 16 Jun 2014, 20:44

since the service ist always crashing I can't setup any devices in the Manager because it always says no copperlan.
I did allready the uninstall and reinstall thing but didn't really help.
sternenkrieger
 
Posts: 8
Joined: 16 Jun 2014, 18:14

Re: 1.3(2) & 1.3(3) Service constantly crashes on Win 8.1 /

Postby CopperPhil » 16 Jun 2014, 20:47

Yes but does it still crash if you physically unplug the USB MIDI devices?
CopperPhil
 
Posts: 471
Joined: 30 Mar 2011, 15:02
Location: Brussels

Re: 1.3(2) & 1.3(3) Service constantly crashes on Win 8.1 /

Postby sternenkrieger » 16 Jun 2014, 21:45

when i unplug all devices the services works, but i can't select a networkdevice
sternenkrieger
 
Posts: 8
Joined: 16 Jun 2014, 18:14

Re: 1.3(2) & 1.3(3) Service constantly crashes on Win 8.1 /

Postby CopperPhil » 17 Jun 2014, 06:24

This is very strange, we have several computers running Win8/64 here without any problem. It means that there is something in your configuration causing a trouble in the VNM (the CopperLan service).

Can you please follow this operation list? It is quite technical, let me know if you need help to proceed.

1) Launch regedit, go to HKEY_LOCAL_MACHINE\SOFTWARE\CopperLan\CPVNM, export the sub-tree, rename the .reg file to .txt, zip it with a password and send it to pca@copperlan.org (don't forget to indicate the zip password in the email)
2) stop the CPVNM Service from Windows Services
3) open a console in administrator mode (cmd.exe, run as administrator), then go to c:\Program Files\CopperLan\CPVNM, then launch "cpvnm -console".
Note: It is normal if you see "Ethernet Send DLL Error..." message while your computer is not connected to an Ethernet cable.
=> does it crash?
=> In the console, type "e" and then [Enter]. Do you see the ethernet interface list?
CopperPhil
 
Posts: 471
Joined: 30 Mar 2011, 15:02
Location: Brussels

Re: 1.3(2) & 1.3(3) Service constantly crashes on Win 8.1 /

Postby sternenkrieger » 17 Jun 2014, 12:19

I will try that when I get home... yesterday when I tried to start cpvnm with the console parameter it also crashed..
it worked with 1.3(1) without crashing
sternenkrieger
 
Posts: 8
Joined: 16 Jun 2014, 18:14

Re: 1.3(2) & 1.3(3) Service constantly crashes on Win 8.1 /

Postby CopperPhil » 17 Jun 2014, 12:40

The crash is probably due to some MIDI gear handling, so please disconnect all MIDI device before launching the VNM. Then you can try re-plugging the MIDI stuff one by one to see which one is crashing the VNM. This information in addition to the registry key dump would allow me to get a better view of what could be going wrong.
CopperPhil
 
Posts: 471
Joined: 30 Mar 2011, 15:02
Location: Brussels

Re: 1.3(2) & 1.3(3) Service constantly crashes on Win 8.1 /

Postby sternenkrieger » 17 Jun 2014, 12:55

Yeah since it worked partially after unplugging all midigear, although the manager didn't find any network carts etc
sternenkrieger
 
Posts: 8
Joined: 16 Jun 2014, 18:14

Re: 1.3(2) & 1.3(3) Service constantly crashes on Win 8.1 /

Postby sternenkrieger » 17 Jun 2014, 19:32

The problem is the Korg USB Driver for the Radias, I just installed the new driver ans it still crashes, once I deactivate the device everything works.
sternenkrieger
 
Posts: 8
Joined: 16 Jun 2014, 18:14

Next

Return to Bug report

cron