Copperlan keeps crashing

Copperlan keeps crashing

Postby Grouphome » 11 Apr 2017, 17:46

Hi,

I just updated the copperlan package to 1.4(5).
I tried to make some adjustments to my 5 AL88 setup. (Right now I'm using it as a standalone network. No computer connected)
I connect my Macbook Pro (2011) running El Capt and the copperlan mannager.
When making a few connections, the app crashes/hangs.
Do you know what the problem could be?
Thanks
Grouphome
 
Posts: 11
Joined: 15 Nov 2016, 15:10

Re: Copperlan keeps crashing

Postby CopperPhil » 11 Apr 2017, 18:09

Hi,

No idea... Is it just the CopperLan Manager that is in cause? Can you restart it and continue patching the connections without restarting the computer? Is the Mac connected through WIFI or cabled network?

If you have a crash report, please send it to pca@copperlan.org.

Can you re-install the version 1.4(3) and check if the crash still occurs?

Thanks,

/Phil
CopperPhil
 
Posts: 471
Joined: 30 Mar 2011, 15:02
Location: Brussels

Re: Copperlan keeps crashing

Postby Grouphome » 11 Apr 2017, 18:13

Hi Phill,

It doesn't give me the possibility to get the crash report.
When restarting the program, one or 2 of the al88's fail to be recognized.
Tried it with the older version. But now the settings won't save on one of the AL88's.

The network is connected via cable. So no WIFI.

Thanks
Grouphome
 
Posts: 11
Joined: 15 Nov 2016, 15:10

Re: Copperlan keeps crashing

Postby CopperPhil » 11 Apr 2017, 18:31

That's weird... in this case, the CopperLan Manager is just a control software creating connections, you don't use the CopperLan Manager snapshot feature, exact? you rely on the AL88 current configuration storage since you're working without computer then.

The only cause I see is that you reached some AL88 connection amount limit... its memory is limited, you can't create hundreds of connections like you do on a computer having virtually unlimited resources.

The fact that some AL88 is not responding when you restart the CopperLan Manager may suggest that it is hanging, maybe due to connection overload. But it's just a idea, I never seen this before. And then the CopperLan Manager crash could be caused to an AL88 in a weird state on the network... This situation is unusual and unpredictable...

A solution is to avoid creating full virtual MIDI cables between the AL88. Just connect what you need, on a channel basis. We rarely have to use the 16 channels, and so it should dramatically reduce amount of connections. Then, let's see if you still have the problem.
CopperPhil
 
Posts: 471
Joined: 30 Mar 2011, 15:02
Location: Brussels

Re: Copperlan keeps crashing

Postby Grouphome » 11 Apr 2017, 18:45

Yes,

Let me try that.
On a per channel base.
Hopefully this will solve all the problems!
Thanks for the suggestion.
Grouphome
 
Posts: 11
Joined: 15 Nov 2016, 15:10

Re: Copperlan keeps crashing

Postby Copperhead » 11 Apr 2017, 19:06

Be sure you have carefully avoided any loopbacks.
Infinite copying + merging in a loop does crash the system automatically (same with any non-CopperLan MIDI equipment).
These loops can occur by looping MIDI devices with a "soft-thru" capability (that merges with an output).
There also of the "soft-thru" in computer DAW, used to monitor your play while recording.
The most usual cause is a simple virtual patching mistake while connecting two or more MIDI machines back and forth to a node with the flow being sent again to the same place after it came back.
A simple test is to disconnect temporarily the cables one by one and check if everything works fine all the sudden.
User avatar
Copperhead
Site Admin
 
Posts: 70
Joined: 16 Apr 2011, 11:43
Location: Belgium

Re: Copperlan keeps crashing

Postby Grouphome » 11 Apr 2017, 23:24

So far so good, had some crazy issues. with 1 or 2 interfaces not showing up. But that problem dissapeared.

Thanks!
Grouphome
 
Posts: 11
Joined: 15 Nov 2016, 15:10

Re: Copperlan keeps crashing

Postby Grouphome » 12 Apr 2017, 22:28

Only thing I keep noticing is when I made a channel routing (for instance midi channel 4 from input one on AL88 1 to AL88 3 midi port 4 out channel 4).
There are 2 times the same setting in that channel. How can this be?
I only made 1 connection.
No sync or other settings have been done
Grouphome
 
Posts: 11
Joined: 15 Nov 2016, 15:10

Re: Copperlan keeps crashing

Postby CopperPhil » 12 Apr 2017, 22:50

Do you mean that you see in the CopperLan Manager 2 connections from AL88(1)-Port1-Ch4 -> AL88(3)-Port4-Ch4 ?

That's impossible... the connection endpoints have a unique identity... Except if several devices have the same name on the network, then both connections are different but look similar due to the device name.

Then it could be a display artifact in the CopperLan Manager... do you still see the double connection if you refresh the Manager's view?
CopperPhil
 
Posts: 471
Joined: 30 Mar 2011, 15:02
Location: Brussels

Re: Copperlan keeps crashing

Postby Grouphome » 12 Apr 2017, 23:21

I just redid the setup. And saved it. will check tomorrow.
Thanks for the help!
Grouphome
 
Posts: 11
Joined: 15 Nov 2016, 15:10

Next

Return to Bug report

cron