Page 1 of 2

Setup issue

PostPosted: 20 Jun 2015, 23:13
by Chainlink
I'm having problems getting started with this; I've installed copperlan on 3 pcs, 2 running win 8.1 & 1 xp; I'm stuck on all of them at the same place: nothing shows up on any screen in C manager.Bottom RH of screen says "no copperlan"(Copperlan engine is not running on this computer).I've tried installing the network driver, setting firewall. but no joy. I'm sure it's something simple but ....? I presume this problem is not pc specific but details for one of them are below.


Details for one pc:
Windows 8.1 Professional (x64) (build 9600)
2.67 gigahertz Intel Xeon
Board: Intel Corporation S3420GP E51976-404
Intel(R) 5 Series/3400 Series SATA AHCI Controller
Intel(R) 82578DM Gigabit Network Connection

Copperlan 1.4 on win 8 , 1.3 on xp
Loopmidi 1.0.5 (15)****
IO2 asio4all ****
Reaper v4.78 **** **** makes no difference whether whether running or not.

Re: Setup issue

PostPosted: 20 Jun 2015, 23:54
by CopperPhil

It is strange that you have this issue on 3 PCs, with two different versions of CopperLan and 2 different OS...

Do you have LoopMidi installed on each computer? If so, can you disable it the time to do a test to see if it works better?

"no copperlan" means that the CopperLan Manager is not able to get connected to the cpvnm service.
=> on a windows 8 machine: can you open the task manager, go to Services tab, select CPVNM, right-click and restart it. Does it restart? If so, the PID number should change and the status should be Running.
=> another thing: on windows 8, firewall settings, [allow an app or feature through windows firewall], verify that "CopperLan Manager" and "CopperLan Virtual Network Manager" have their [Private] box checked.

Re: Setup issue

PostPosted: 21 Jun 2015, 00:03
by Chainlink
Thanks . will give these a go tomorrow

Re: Setup issue

PostPosted: 21 Jun 2015, 16:45
by Chainlink
Hi again.
Did what you suggested re dis-abling loopmidi, firewall and CPVNM, restarting. Yes it restarts, the PID number changes and the status is " Running." Doesn't solve though.

However I now think this is an install issue:
This morning I also ran the installer on a windows 7 setup, which seemed to work fine . The install procedure was different; it asked me permission to install the various drivers separately, ie I had to agree 4 times. This did not happen on any of my 3 previous installs. To verify this I uninstalled Copperlan on my two win 8-1 machines then reinstalled it . In both cases it was a one-step procedure and in both nothing shows when I opened the the manager.
I tried running( as admin) Drivers Installation.exe on one and it wouldn't open. Perhaps that has something to do with it?



Re: Setup issue

PostPosted: 21 Jun 2015, 20:25
by Chainlink
PS the win 7 pc is showing up in C Man on the other pcs now

Re: Setup issue

PostPosted: 18 Jul 2015, 14:49
by Chainlink
Hi again. Still haven't resolved this. Am I just being stupid or is there a problem with the installer?


Re: Setup issue

PostPosted: 18 Jul 2015, 22:42
by CopperPhil

Yes, it seems that you have trouble with the installer on your Win8 machines, the Win7 PC seems to be working fine now.

If you disconnect the Win7 computer, what is the bottom right status in the CopperLan Manager running on a Win8 machine? Ethernet? Local? No CopperLan? If you go then to the Manager's settings, do you see the list of Ethernet interfaces?

Finally, here is a procedure that could give us more information. Please do that from one of your Win8 machines:
1) stop the CPVNM service
2) open a command console in administrator mode (cmd.exe from start menu search, right click and "run as administrator)
3) ensure you are on disk C:
4) cd C:\Program Files\CopperLan\CPVNM
5) check the console's properties and ensure that Screen Buffer Size Height is high (ex: 1000) in the Layout tab.
6) cpvnm -console
7) Select all the content of the console, copy-paste in a post hereafter.
8) type "N [enter]" (this is a command displaying network control info), copy-paste in a post hereafter.
9) and finally, same thing with "T [enter]" to get transport statistics, copy-paste in a post hereafter.

In order to resume standard working context, "x [enter]" to terminate the VNM, close the command console, and restart the CPVNM service.

Re: Setup issue

PostPosted: 19 Jul 2015, 16:51
by Chainlink
Ok When Win 7 connected ,shows status Ethernet
" disconnected " " No CopperLan
No ethernet list shown.
Results of your procedure:
Manual start...
TCPIP Port: 40987
Available commands:
X Exit
D Device table
N Network control
C Destination cache
R Reset statistics
S Statistics
T Transport
M Link manager
E List available ethernet interfaces
A Allocated memory
L Log options

Network Control:
Own: Unknown[127]
Neighbor list:
Bottom list:
Is Clock Master : True
Clock Master : Unknown[127]

No transport interfaces


Re: Setup issue

PostPosted: 19 Jul 2015, 19:50
by Chainlink
P.S. Sorry, the above didn't dislpay as I wrote it: 2nd line should read

"When disconnected it shows 'No CopperLan' "

Re: Setup issue

PostPosted: 19 Jul 2015, 21:27
by CopperPhil
OK this confirm what I suspected. The CopperLan Manager running on your Win8 computer is hosted by the VNM running in the Win7 PC, this means that the Win8 VNM is unreachable, or frozen for some reason.

There is another thread from a user having a similar problem (viewtopic.php?f=7&t=310). It looks like some 3rd party software is disturbing the MIDI support, and consequently the VNM health. We found this issue for the first time on Mac, after un upgrade to MacOSX Yosemite. Some MIDI drivers are no more working under Yosemite, but there is no warning, nor clear information about that. It is resulting in blocking MIDI related system calls freezing the VNM.

From the log you copy-paste, it is clear that either no network interface is detected by the VNM, or the VNM is frozen before it was able to initiate the transport layer.

You should see something like this at the startup:
Code: Select all
C:\Program Files\CopperLan\CPVNM>cpvnm -console
TCPIP Port: 40987
21:16:06.928            LM      2 plugins found
21:16:06.928            LM      Plugin: Klavis Technologies CHAI over TCP/IP Port [] [] (Port Allocates Read Buffer)
21:16:06.929            LM      Plugin: ICT7 S.A. CHAI Link over USB Port Driver [] [] (Port Allocates Read Buffer)(FrameTransport)

Can you verify that this folder is present C:\Program Files\CopperLan\CPVNM\CLP
and contain at least one *.clp file?

If you have any MIDI interface attached to the computer, please try to unplug it and restart the CPVNM service.

You told before that you disabled Loopmidi, but maybe this is not enough. Can you open the device manager, search for any loopmidi virtual MIDI driver, and disable it?