Copperlan driver won't install in Windows 10 Creators Update

Copperlan driver won't install in Windows 10 Creators Update

Postby nicotux » 04 Aug 2017, 03:17


When installating CopperLanSetup[20170224_1.4(5)].exe everything seems OK
- CopperLanManager popup self identify as 12.2
- Support always say there is a new version 1.4(5) available and ask to install if
- Midi are listed but disapear quickly
- Networks disapear sometimes

As found in this forum, Yes this is related to service not running correctly
but Why exactly ?
Because of something uggly : the driver is not installed !!

in Devices Manager I see
Other peripherals -> Unknown peripheral
details : ROOT\*CPVMIDI\0000

Trying to manually install give the error ... The driver for your device was found but was not correctly installed file is missing

manually trying to merge .inf file to system result in ... The driver is not for this platform
which seems to be really the case according to the home page
Windows® (XP32; Vista, Seven and 8 - in 32 and 64-bit versions)

The strange thing is ... this was well working previously before updating

I found the version for windows-8-7-vista-32-bit-and-64-bit-2x64 which this time does a little bit less
it hangs at Initial Setup saying "Verifying Ethernet interface selection, please wait..."

here is the related administration event
<Event xmlns="">
- <System>
<Provider Name="Microsoft-Windows-DeviceSetupManager" Guid="{FCBB06BB-6A2A-46E3-ABAA-246CB4E508B2}" />
<TimeCreated SystemTime="2017-08-04T01:07:30.986938400Z" />
<Correlation />
<Execution ProcessID="6608" ThreadID="2608" />
<Security UserID="S-1-5-18" />
- <EventData>
<Data Name="Prop_DevnodeId">ROOT\*CPVMIDI\0000</Data>
<Data Name="HRESULT">2149844024</Data>

after what, there is no network detection, no midi created, CopperlanManager loose the detected synth if asked to send active sensing, killing service

Nom de l’application défaillante CPVNM.exe, version :, horodatage : 0x58c9395d
Nom du module défaillant : CPVNM.exe, version :, horodatage : 0x58c9395d
Code d’exception : 0xc0000005
Décalage d’erreur : 0x0000000000018af3
ID du processus défaillant : 0x138
Heure de début de l’application défaillante : 0x01d30cc07eeede40
Chemin d’accès de l’application défaillante : C:\Program Files\CopperLan\CPVNM\CPVNM.exe
Chemin d’accès du module défaillant: C:\Program Files\CopperLan\CPVNM\CPVNM.exe
ID de rapport : 8a203184-2775-49e2-915a-257d6f4ed8ab
Nom complet du package défaillant :
ID de l’application relative au package défaillant :
Screenshot of Device Manager (sorry, it is in french, but who really care)
Posts: 2
Joined: 04 Aug 2017, 02:34

Re: Copperlan driver won't install in Windows 10 Creators Up

Postby CopperPhil » 04 Aug 2017, 08:13

Thank you very much for you feedback!

Did you get this problem with a fresh install of CopperLan, or next to the Windows upgrade?

I've here a Windows Surface Pro that got the Windows 10 Creators upgrade last night, and it is working fine today. However I had to confirm access to local network when I launched the CopperLan Manager (the firewall settings changed during the system update).

We already had a similar issue during previous system updates, it seems that the driver registration is sometimes not upgraded properly (not always, it depends on the computer).

In this case, we advise to re-install CopperLan in order to repair the driver registration. If it is not yet working, uninstall CopperLan, reboot, then re-install it (but beware! this procedure changes the computer's ID in the CopperLan network, making previous snapshots obsolete). I just did it here to check that the 1.4(5) package from our web site is working properly.

Let me know if this solves your problem.
Posts: 480
Joined: 30 Mar 2011, 15:02
Location: Brussels

Re: Copperlan driver won't install in Windows 10 Creators Up

Postby nicotux » 05 Aug 2017, 10:24


Well, it was a fresh install for both windows 10 and Copperlan followed by a click on "download and install" in "about" section of copperlan manager :evil:

Rebooting then reinstalling copperlan manager (which pretends to be 1.2) didn't fix anything

However i finally found a solution which worked for me :idea: :arrow: :

1) uninstall copperlan manager and reboot (not everything will go)

2) go to device manager and click "show hiden devices"

3) under "audio video game controllers" select "Copperlan Virtual Midi Driver" and uninstall device

4) under "audio I/O" uninstall every hiden instances of vmidi

5) close device manager

6) navigate to %windows%/system32\DriverStore\FileRepository
(needs to display hidden files and system files)

7) appropriate and delete
- cpoethprot.inf_amd64_*
- cpvirtualmidi.inf_amd64_*
( it is important to delete these folders not only their contents otherwhise system will think drivers are already present and even if it does not, permissions would be wrong)

8) REBOOT again

9) in device manager verify copperlan is not a driver provider anymore
(manualy fake update any driver (...on this computer, in a list) to get the list of driver providers of which copperlan must have disapear) do not close it

10) install Copperlan Manager as usual
at end DO NOT CLICK "Next" immmediately slowly wait for device manager to finish installing everything
( it looks like the problem was there :roll: )

11) once stabilized, click next then choose network as usual

12) enjoy :)

I didn't try everything else but manager not loosing network or midi devices

Thanks for the answer
Posts: 2
Joined: 04 Aug 2017, 02:34

Re: Copperlan driver won't install in Windows 10 Creators Up

Postby chrisfoster » 11 Nov 2017, 02:48

nicotux wrote:
However i finally found a solution which worked for me

Thanks for documenting this, it could also be a useful technique for dealing with other windows driver issues.


Posts: 68
Joined: 09 Sep 2013, 23:23
Location: Australia

Return to Windows and Mac installation