Trouble installing on Windows 10

Trouble installing on Windows 10

Postby auricle » 02 Dec 2015, 21:45

Hi,

I'm having trouble installing Copperlan on my Windows 10 64bit machine.

I have installed the manager but it doesn't detect anything on my network (AL-88c) in fact the manager window is blank and it doesn't detect my network card in the manager settings.

I did notice one problem. When checking the network adaptor properties - I notice that the CopperLan over Ethernet Protocol wasn't installed. I tried to install it but it gave me an access denied error even though I am the administrator on this machine.

Any ideas what the issue may be?

*edit* I played around with the firewall settings (I have Kaspersky installed) and now I can see the computer in the manager. It still can't detect the network card though.
auricle
 
Posts: 4
Joined: 02 Dec 2015, 21:41

Re: Trouble installing on Windows 10

Postby CopperPhil » 02 Dec 2015, 22:06

Hi,

We don't know any compatibility issue with Win-10 64 so far... But the problem related to the driver installation you mentioned is certainly the cause. The CopperLan package can't work without Ethernet driver properly installed.

Kapersky firewall/shield might be involved... Can you try to uninstall CopperLan, reboot, disable Kapersky, then install CopperLan running the installer "as an administrator" ? Then if the config is working find, re-enable Kapersky with needed exception (the CPVNM service must be free of access limitation).
CopperPhil
 
Posts: 478
Joined: 30 Mar 2011, 15:02
Location: Brussels

Re: Trouble installing on Windows 10

Postby auricle » 02 Dec 2015, 22:25

hi Phil,

I tried what you suggested but still the same issue. I also right clicked on the copperlan manager installer and selected 'run as administrator' but still the same result. The Copperlan Network Protocol isn't running on the adapter and I still get an access denied error when I manually try to add it.

Interestingly, when I open the Copperlan manager with Kaspersky disabled the local computer is missing! Something strange is going on.

*edit* I'm sure that as soon as I add the Copperlan Network Protocol to my network card everything will work. I just need to find out what is locking me out of the network adapter settings. I even tried starting the network adapter window from an administrator command prompt but that didn't work either.

I can't find an answer on the internet so far :cry:

CopperPhil wrote:Hi,

We don't know any compatibility issue with Win-10 64 so far... But the problem related to the driver installation you mentioned is certainly the cause. The CopperLan package can't work without Ethernet driver properly installed.

Kapersky firewall/shield might be involved... Can you try to uninstall CopperLan, reboot, disable Kapersky, then install CopperLan running the installer "as an administrator" ? Then if the config is working find, re-enable Kapersky with needed exception (the CPVNM service must be free of access limitation).
auricle
 
Posts: 4
Joined: 02 Dec 2015, 21:41

Re: Trouble installing on Windows 10

Postby CopperPhil » 02 Dec 2015, 23:11

Actually I have no idea about what could go wrong.

It seems that the driver is installed, but something is preventing it to start... I do not hide my suspicions are on Kapersky. But I don't know precisely this program so I can't give any advice to try this or that.

Maybe can you have a look at the Windows Event logs to check if you find something related to the CopperLan Over Ethernet driver starting attempts? An error code or something could help to understand why it fails to start...
CopperPhil
 
Posts: 478
Joined: 30 Mar 2011, 15:02
Location: Brussels

Re: Trouble installing on Windows 10

Postby auricle » 03 Dec 2015, 10:11

It was indeed Kaspersky. I uninstalled it and rebooted. I was then able to install the Copperlan Ethernet protocol which then allowed the Copperlan manager to detect my network card and therefore my AL-88c.

Thank you very much for your help, Phil.
auricle
 
Posts: 4
Joined: 02 Dec 2015, 21:41


Return to Windows and Mac installation

cron